aboutsummaryrefslogtreecommitdiffstats
path: root/test/afb-test/etc/CMakeLists.txt
diff options
context:
space:
mode:
authorEdi Feschiyan <edi.feschiyan@konsulko.com>2019-05-03 12:07:20 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-19 13:09:24 +0000
commitf26b124ec8c70f933eb8f7ec7d991b4ab822b210 (patch)
treeec7a4a058f0d5b8d25e1b92458258150dee327c1 /test/afb-test/etc/CMakeLists.txt
parentcdde249296cbfd4ca9778468208814968f9a34d8 (diff)
Bug-AGL: SPEC-2526 Change-Id: I96251cc7880348253ffced94d5373492cd52b244 Signed-off-by: Edi Feschiyan <edi.feschiyan@konsulko.com>
Diffstat (limited to 'test/afb-test/etc/CMakeLists.txt')
-rw-r--r--test/afb-test/etc/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/test/afb-test/etc/CMakeLists.txt b/test/afb-test/etc/CMakeLists.txt
new file mode 100644
index 0000000..472f591
--- /dev/null
+++ b/test/afb-test/etc/CMakeLists.txt
@@ -0,0 +1,32 @@
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# author:Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+##################################################
+# geoclue test configuration files
+##################################################
+PROJECT_TARGET_ADD(afb-test-config)
+
+ file(GLOB CONF_FILES "*.json")
+
+ add_input_files("${CONF_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "TEST-CONFIG"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+