summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-08-10 11:13:22 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2017-08-28 10:50:57 -0700
commit94af7aa13b923fb96c152c4cb4251fe415271a91 (patch)
tree0123fa884d3baad0a39b011a7342cd2027ab9c06 /CMakeLists.txt
parent86b7ee8c78b62b562e1d4aa3ea9e94ade330f2b8 (diff)
binding: gps: move build to cmake
Enable cmake build system for building webpack wgt, and remove unnecessary files Change-Id: Ia00b1ba7a9d26e7f8933c0ccc97bf8b91dbfa012 Bug-AGL: SPEC-823 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 4 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4a94b8..b485097 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
###########################################################################
-# Copyright 2016 IoT.bzh
+# Copyright 2015, 2016, 2017 IoT.bzh
#
-# author: José Bollo <jose.bollo@iot.bzh>
+# author: Romain Forlot <romain.forlot@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -16,19 +16,6 @@
# limitations under the License.
###########################################################################
-project(af-gps-binding C)
-
-cmake_minimum_required(VERSION 3.3)
-
-include(GNUInstallDirs)
-
-set(PROJECT_NAME "af-gps-binding")
-set(PROJECT_PRETTY_NAME "af binding for GPS")
-set(PROJECT_DESCRIPTION "Binding for handling NMEA signalisation of GPS")
-set(PROJECT_VERSION "1.0")
-
-set(CMAKE_BUILD_TYPE Debug)
-
-add_subdirectory(src)
-
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)