aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 4 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4a94b8..b485097 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
###########################################################################
-# Copyright 2016 IoT.bzh
+# Copyright 2015, 2016, 2017 IoT.bzh
#
-# author: José Bollo <jose.bollo@iot.bzh>
+# author: Romain Forlot <romain.forlot@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -16,19 +16,6 @@
# limitations under the License.
###########################################################################
-project(af-gps-binding C)
-
-cmake_minimum_required(VERSION 3.3)
-
-include(GNUInstallDirs)
-
-set(PROJECT_NAME "af-gps-binding")
-set(PROJECT_PRETTY_NAME "af binding for GPS")
-set(PROJECT_DESCRIPTION "Binding for handling NMEA signalisation of GPS")
-set(PROJECT_VERSION "1.0")
-
-set(CMAKE_BUILD_TYPE Debug)
-
-add_subdirectory(src)
-
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)