aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-09-29 20:42:53 +0900
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-05 13:37:43 +0900
commite0163d2b8daae98ced81f4bc737998c00858e771 (patch)
treeaba44cb1b2878bb010c87474a95fc57d1d74380c /CMakeLists.txt
parent613f4b2e32cc84b3b1e76e3481cf0a08b4c1ea12 (diff)
Add agl-service-homescreen-2017
Add a new binding agl-service-homescreen-2017 for homescreen-2017. There is a gles sample how to use this binding in sample/simple-egl. A image about this see JIRA SPEC-871. [PatchSets2] Use aglwgt make package. Change-Id: I9ae89188f9eb2de4c98ec8baa2f05fccca8b2372 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..57f56b1
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,47 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+project(HomeScreenService C CXX)
+
+cmake_minimum_required(VERSION 3.0)
+
+set(PROJECT_NAME "HomeScreen Service and client library")
+set(PROJECT_VERSION "1.0")
+set(PROJECT_PRETTY_NAME "HM")
+set(PROJECT_DESCRIPTION "HomeScreen Service and client library")
+set(PROJECT_INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_INCLUDEDIR})
+set(PROJECT_LIBDIR ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+set(binding_install_dir ${PREFIX}/lib/homescreen)
+set(PROJECT_BINDINGDIR ${binding_install_dir})
+set(LIBSM_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/include)
+
+# get pkgconfig
+INCLUDE(FindPkgConfig)
+link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
+
+set(CMAKE_BUILD_TYPE Debug)
+set(DEBUGMODE "1")
+add_definitions(-DDEBUGMODE)
+
+add_subdirectory(src)
+add_subdirectory(libhomescreen)
+add_subdirectory(include)
+
+#generate configure file
+configure_file(homescreen.pc.in homescreen.pc @ONLY)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/homescreen.pc
+ DESTINATION
+ ${CMAKE_INSTALL_LIBDIR}/pkgconfig)