aboutsummaryrefslogtreecommitdiffstats
path: root/libhomescreen/CMakeLists.txt
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-09-29 20:42:53 +0900
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-05 13:37:43 +0900
commite0163d2b8daae98ced81f4bc737998c00858e771 (patch)
treeaba44cb1b2878bb010c87474a95fc57d1d74380c /libhomescreen/CMakeLists.txt
parent613f4b2e32cc84b3b1e76e3481cf0a08b4c1ea12 (diff)
Add agl-service-homescreen-2017
Add a new binding agl-service-homescreen-2017 for homescreen-2017. There is a gles sample how to use this binding in sample/simple-egl. A image about this see JIRA SPEC-871. [PatchSets2] Use aglwgt make package. Change-Id: I9ae89188f9eb2de4c98ec8baa2f05fccca8b2372 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'libhomescreen/CMakeLists.txt')
-rw-r--r--libhomescreen/CMakeLists.txt58
1 files changed, 58 insertions, 0 deletions
diff --git a/libhomescreen/CMakeLists.txt b/libhomescreen/CMakeLists.txt
new file mode 100644
index 0000000..b9dc94b
--- /dev/null
+++ b/libhomescreen/CMakeLists.txt
@@ -0,0 +1,58 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+
+cmake_minimum_required(VERSION 3.0)
+
+set(TARGET_LIBHS homescreen)
+add_definitions("-std=c++11")
+
+pkg_check_modules(libhs_depends json-c libafbwsc libsystemd)
+set(libhs_sources libhomescreen.cpp)
+
+include_directories(${LIBSM_INCLUDE_DIR})
+link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
+
+add_library(${TARGET_LIBHS} SHARED ${libhs_sources})
+target_compile_options(${TARGET_LIBHS} PUBLIC ${libhs_depends_CFLAGS})
+
+if(DEFINED DEBUGMODE)
+ target_compile_options(${TARGET_LIBHS} PRIVATE -g -O0)
+else(DEFINED DEBUGMODE)
+ target_compile_options(${TARGET_LIBHS} PRIVATE -g -O2)
+endif(DEFINED DEBUGMODE)
+
+include_directories(${TARGET_LIBHS} ${libhs_depends_INCLUDE_DIRS})
+target_link_libraries(${TARGET_LIBHS} afbwsc -lpthread ${link_libraries} ${libhs_depends_LIBRARIES})
+
+if(DEFINED CMAKE_INSTALL_LIBDIR)
+ INSTALL(TARGETS ${TARGET_LIBHS}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+endif(DEFINED CMAKE_INSTALL_LIBDIR)
+
+#####################
+pkg_check_modules(test_depends glib-2.0 gio-2.0 gio-unix-2.0)
+add_executable(libhomescreen-demo test.cpp)
+include_directories(libhomescreen-demo ${test_depends_INCLUDE_DIRS})
+TARGET_LINK_LIBRARIES(libhomescreen-demo
+ homescreen
+ ${link_libraries}
+ -lpthread
+ ${test_depends_LIBRARIES}
+ ${libhs_depends_LIBRARIES}
+)
+#####################
+#add_subdirectory(test)