summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-05-26 17:49:50 -0400
committerScott Murray <scott.murray@konsulko.com>2020-05-26 18:27:40 -0400
commit89edd734c0a347dafceba1cef1ac835e0fe61e1a (patch)
treed54ef3bc130749b9c4241f22663b508c697af9f5 /src/CMakeLists.txt
parent055909f4a7b27003bdd60c1cee764cf1d23be9cc (diff)
Fix CMake files and non-debug crashes
Changes include: - Reworked src/CMakeLists.txt to use app template macros. - Removed now unnecessary linker script, symbol exports are handled in the app template macros. - Set missing required entries in conf.d/cmake/config.cmake, and update to match latest template version in cmake-apps-module, as well as some naming fixes in the PROJECT* definitions. - Move project definition to top-level CMakeLists.txt to make tracking conf.d/cmake/config.cmake changes easier. This quiets the warning from newer versions of CMake about needing a project definition in the top-level CMakeLists.txt. - Moved icon file to default location for app template. - Added config.xml.in file to work with app template, replacing previous hard-coded version. - Fixed some issues in src/hs-clientmanager.{h,cpp} to address crashes seen in the release widget now that it is actually built without debug flags, and to quiet some warnings. Bug-AGL: SPEC-3343 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3741e6a307297272d5c22e894dfa9ff8b0dd1f52
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt67
1 files changed, 18 insertions, 49 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 98dc27c..b415443 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,6 @@
#
# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+# Copyright (C) 2020 Konsulko Group
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -14,58 +15,26 @@
# limitations under the License.
#
-cmake_minimum_required(VERSION 2.8)
+PROJECT_TARGET_ADD(homescreen-binding)
-set(TARGETS_HSBINDER homescreen-service)
+add_definitions(-DAFB_BINDING_VERSION=3)
-INCLUDE(FindThreads)
-FIND_PACKAGE(Threads)
-
-pkg_check_modules(hs_binding_depends afb-daemon glib-2.0 gio-2.0 gio-unix-2.0 json-c)
-set(binding_hs_sources
- homescreen.cpp
- hs-helper.cpp
- hs-clientmanager.cpp
- hs-client.cpp
- hs-proxy.cpp
- hs-appinfo.cpp)
-
-link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
-include_directories(${PROJECT_SOURCE_DIR}/include)
-add_library(${TARGETS_HSBINDER} MODULE ${binding_hs_sources})
-
-target_compile_options(${TARGETS_HSBINDER} PRIVATE ${hs_binding_depends_CFLAGS})
-if(DEFINED DEBUGMODE)
- target_compile_options(${TARGETS_HSBINDER} PRIVATE -g -O0)
-else(DEFINED DEBUGMODE)
- target_compile_options(${TARGETS_HSBINDER} PRIVATE -g -O2)
-endif(DEFINED DEBUGMODE)
-
-target_include_directories(${TARGETS_HSBINDER} PRIVATE ${hs_binding_depends_INCLUDE_DIRS})
-target_link_libraries(${TARGETS_HSBINDER} ${CMAKE_THREAD_LIBS_INIT} ${link_libraries} ${hs_binding_depends_LIBRARIES})
+# Define project Targets
+add_library(${TARGET_NAME} MODULE
+ homescreen.cpp
+ hs-helper.cpp
+ hs-clientmanager.cpp
+ hs-client.cpp
+ hs-proxy.cpp
+ hs-appinfo.cpp)
# Binder exposes a unique public entry point
-
-set_target_properties(${TARGETS_HSBINDER} PROPERTIES
- PREFIX ""
- LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
- )
-
-# installation directory
-#INSTALL(TARGETS ${TARGETS_HSBINDER}
-# LIBRARY DESTINATION ${binding_install_dir})
-
-if(NOT EXISTS ${PROJECT_BINARY_DIR}/package)
- add_custom_command(TARGET ${TARGETS_HSBINDER} POST_BUILD
- COMMAND cp -rf ${PROJECT_SOURCE_DIR}/package ${PROJECT_BINARY_DIR}
- )
-endif()
-
-add_custom_command(TARGET ${TARGETS_HSBINDER} POST_BUILD
- COMMAND mkdir -p ${PROJECT_BINARY_DIR}/package/root/lib
- COMMAND cp -rf ${PROJECT_BINARY_DIR}/src/${TARGETS_HSBINDER}.so ${PROJECT_BINARY_DIR}/package/root/lib
+SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "BINDING"
+ PREFIX ""
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
)
-add_custom_target(package DEPENDS ${PROJECT_BINARY_DIR}/package/root
- COMMAND wgtpkg-pack -f -o ${PROJECT_BINARY_DIR}/package/${TARGETS_HSBINDER}.wgt ${PROJECT_BINARY_DIR}/package/root
-)
+# Library dependencies (include updates automatically)
+TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})