summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorwang_zhiqiang <wang_zhiqiang@dl.cn.nexty-ele.com>2018-10-09 10:31:06 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-10-17 20:10:26 +0000
commitea459cc8988c3e664c3f9d56d3a9929775d8b57b (patch)
tree0fd0fbc929a5a5b8b8eb1a9eccc0e411f5106261 /src/CMakeLists.txt
parent28b7b54a65f7954c4e279e22d2ff4f49ccc39f7f (diff)
emit event to one application
changed agl-service-homescreen and libhomescreen to make agl-service-homescreen emit event to one application only. BUG-AGL: SPEC-1764 Change-Id: I87e4fc8fe900fdf9d7fde04852077c7174b8a3ba Signed-off-by: wang_zhiqiang <wang_zhiqiang@dl.cn.nexty-ele.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index dbd7fbe..bf8b33f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -24,7 +24,9 @@ FIND_PACKAGE(Threads)
pkg_check_modules(hs_binding_depends afb-daemon glib-2.0 gio-2.0 gio-unix-2.0 json-c)
set(binding_hs_sources
homescreen.cpp
- hs-helper.cpp)
+ hs-helper.cpp
+ hs-clientmanager.cpp
+ hs-client.cpp)
link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
include_directories(${PROJECT_SOURCE_DIR}/include)