aboutsummaryrefslogtreecommitdiffstats
path: root/agl-identity-service/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Collignon <loic.collignon@iot.bzh>2017-12-19 17:15:55 +0100
committerLoïc Collignon <loic.collignon@iot.bzh>2017-12-19 17:15:55 +0100
commit4f87bf2d5e0154df8b063948a80d90d614a83252 (patch)
treeaee213912c7972ff8913753264f97b4c0734679c /agl-identity-service/src/CMakeLists.txt
parent4d710564d4ba6ed525ad05fea03310857abd4d63 (diff)
added a fake auth verb for testing purpose and use persistence api to store user profile.
Change-Id: Ifc38f01664dec91150ca7574e4263ee0bc755653 Signed-off-by: Loïc Collignon <loic.collignon@iot.bzh>
Diffstat (limited to 'agl-identity-service/src/CMakeLists.txt')
-rw-r--r--agl-identity-service/src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/agl-identity-service/src/CMakeLists.txt b/agl-identity-service/src/CMakeLists.txt
index 1ceb851..2e86ecc 100644
--- a/agl-identity-service/src/CMakeLists.txt
+++ b/agl-identity-service/src/CMakeLists.txt
@@ -41,3 +41,7 @@ set_target_properties(afb-identity-binding PROPERTIES
OUTPUT_NAME "${TARGET_NAME}"
)
+add_custom_command(TARGET ${TARGET_NAME}
+PRE_BUILD
+COMMAND mkdir -p ${CMAKE_CURRENT_BINARY_DIR}/../package/htdocs
+COMMAND cp -rv ${CMAKE_CURRENT_SOURCE_DIR}/../htdocs ${CMAKE_CURRENT_BINARY_DIR}/../package/)