summaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-10-31 10:50:24 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-10-31 10:50:24 +0100
commit2ca7f3a4a03db3e7d7fa15504fa3d69e1c6bd217 (patch)
tree7dc6ff7e6efab4eeca79681efb672ed07061a545 /binding/CMakeLists.txt
parent2ffcc61a750a2bf4598662b4612283fdc9d2a4e4 (diff)
Split in two: agl-identity-service and uds-ble-id-init-service
The binding is splitted in two parts and packeged as widgets. The two parts are: - uds-ble-id-init-service This service provides a UDS (User Data Service) over BLE. It detects writes to the email of the user to initiate the authentication process. - agl-identity-service This service queries the Forgerock's Edge Controller to fill user data and make it available. The actual code is not fully functionnal. Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt53
1 files changed, 0 insertions, 53 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
deleted file mode 100644
index b244009..0000000
--- a/binding/CMakeLists.txt
+++ /dev/null
@@ -1,53 +0,0 @@
-###########################################################################
-# Copyright 2016 IoT.bzh
-#
-# author: José Bollo <jose.bollo@iot.bzh>
-# author: Stéphane Desneux <stephane.desneux@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-cmake_minimum_required(VERSION 3.3)
-
-###########################################################################
-
-include(FindPkgConfig)
-
-pkg_check_modules(EXTRAS REQUIRED json-c afb-daemon libcurl systemd)
-add_compile_options(${EXTRAS_CFLAGS} -DFOR_AFB_BINDING)
-include_directories(${EXTRAS_INCLUDE_DIRS})
-link_libraries(${EXTRAS_LIBRARIES})
-
-add_library(${PROJECT_NAME} MODULE
- agl-identity-binding.c
- aia-get.c
- aia-uds-bluez.c
- authorization.c
- base64.c
- curl-wrap.c
- escape.c
- oidc-agent.c
-)
-set_target_properties(${PROJECT_NAME} PROPERTIES
- PREFIX ""
- LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
-)
-
-install(TARGETS ${PROJECT_NAME} DESTINATION ${PROJECT_DESTINATION})
-
-INSTALL(FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/config.json
- DESTINATION
- ${PROJECT_DESTINATION}
- )
-