aboutsummaryrefslogtreecommitdiffstats
path: root/uds-ble-id-init-service/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-10-31 10:50:24 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-10-31 10:50:24 +0100
commit2ca7f3a4a03db3e7d7fa15504fa3d69e1c6bd217 (patch)
tree7dc6ff7e6efab4eeca79681efb672ed07061a545 /uds-ble-id-init-service/src/CMakeLists.txt
parent2ffcc61a750a2bf4598662b4612283fdc9d2a4e4 (diff)
Split in two: agl-identity-service and uds-ble-id-init-service
The binding is splitted in two parts and packeged as widgets. The two parts are: - uds-ble-id-init-service This service provides a UDS (User Data Service) over BLE. It detects writes to the email of the user to initiate the authentication process. - agl-identity-service This service queries the Forgerock's Edge Controller to fill user data and make it available. The actual code is not fully functionnal. Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'uds-ble-id-init-service/src/CMakeLists.txt')
-rw-r--r--uds-ble-id-init-service/src/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/uds-ble-id-init-service/src/CMakeLists.txt b/uds-ble-id-init-service/src/CMakeLists.txt
new file mode 100644
index 0000000..97e229a
--- /dev/null
+++ b/uds-ble-id-init-service/src/CMakeLists.txt
@@ -0,0 +1,35 @@
+###########################################################################
+# Copyright 2017 IoT.bzh
+#
+# author: Jose Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+PROJECT_TARGET_ADD(afb-uds-ble-id-init-binding)
+
+add_library(afb-uds-ble-id-init-binding MODULE
+ uds-ble-id-init-service.c
+ aia-uds-bluez.c
+)
+
+set_target_properties(afb-uds-ble-id-init-binding PROPERTIES
+ LABELS "BINDING"
+ PREFIX ""
+ COMPILE_FLAGS "${libsystemd_CFLAGS}"
+ INCLUDE_DIRECTORIES "${libsystemd_INCLUDE_DIRS}"
+ LINK_FLAGS "${BINDINGS_LINK_FLAG}"
+ LINK_LIBRARIES "${libsystemd_LIBRARIES}"
+ OUTPUT_NAME "${TARGET_NAME}"
+)
+