aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt56
1 files changed, 7 insertions, 49 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d9d7bd1..7ef4f7a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,7 @@
###########################################################################
-# Copyright 2016 IoT.bzh
+# Copyright 2017 IoT.bzh
#
-# author: José Bollo <jose.bollo@iot.bzh>
-# author: Stéphane Desneux <stephane.desneux@iot.bzh>
+# author: Jose Bollo <jose.bollo@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -17,51 +16,10 @@
# limitations under the License.
###########################################################################
-cmake_minimum_required(VERSION 3.3)
-
-project(agl-identity-agent VERSION 0.1)
-
-include(GNUInstallDirs)
-include(FindPkgConfig)
-
-###########################################################################
-
-set(CMAKE_BUILD_TYPE Debug CACHE STRING "set debug build by default")
-
-link_libraries(-Wl,--as-needed -Wl,--gc-sections)
-
-add_compile_options(-Wall -Wextra -Wconversion)
-add_compile_options(-Wno-unused-parameter) # frankly not using a parameter does it care?
-add_compile_options(-Wno-unused-but-set-variable)
-add_compile_options(-Werror=maybe-uninitialized)
-add_compile_options(-Werror=implicit-function-declaration)
-add_compile_options(-ffunction-sections -fdata-sections)
-add_compile_options(-Wl,--as-needed -Wl,--gc-sections)
-add_compile_options(-fPIC)
-
-set(CMAKE_C_FLAGS_PROFILING "-g -O0 -pg -Wp,-U_FORTIFY_SOURCE")
-set(CMAKE_C_FLAGS_DEBUG "-g -O0 -ggdb -Wp,-U_FORTIFY_SOURCE")
-set(CMAKE_C_FLAGS_RELEASE "-g -O2")
-set(CMAKE_C_FLAGS_CCOV "-g -O2 --coverage")
-
-###########################################################################
-
-set(PROJECT_DESTINATION ${CMAKE_INSTALL_FULL_LIBEXECDIR}/${PROJECT_NAME})
-
-###########################################################################
-
-add_subdirectory(binding)
-
-###########################################################################
-
-configure_file(agl-identity-agent.service.in agl-identity-agent.service @ONLY)
-
-INSTALL(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/agl-identity-agent.service
- ${CMAKE_CURRENT_SOURCE_DIR}/btle-advise.service
- ${CMAKE_CURRENT_SOURCE_DIR}/btle-advise.timer
- DESTINATION
- ${PROJECT_DESTINATION}
- )
+cmake_minimum_required(VERSION 3.6)
+SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+install(DIRECTORY etc DESTINATION ./)
+install(DIRECTORY htdocs/identity DESTINATION htdocs)