summaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt53
1 files changed, 0 insertions, 53 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
deleted file mode 100644
index b244009..0000000
--- a/binding/CMakeLists.txt
+++ /dev/null
@@ -1,53 +0,0 @@
-###########################################################################
-# Copyright 2016 IoT.bzh
-#
-# author: José Bollo <jose.bollo@iot.bzh>
-# author: Stéphane Desneux <stephane.desneux@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-cmake_minimum_required(VERSION 3.3)
-
-###########################################################################
-
-include(FindPkgConfig)
-
-pkg_check_modules(EXTRAS REQUIRED json-c afb-daemon libcurl systemd)
-add_compile_options(${EXTRAS_CFLAGS} -DFOR_AFB_BINDING)
-include_directories(${EXTRAS_INCLUDE_DIRS})
-link_libraries(${EXTRAS_LIBRARIES})
-
-add_library(${PROJECT_NAME} MODULE
- agl-identity-binding.c
- aia-get.c
- aia-uds-bluez.c
- authorization.c
- base64.c
- curl-wrap.c
- escape.c
- oidc-agent.c
-)
-set_target_properties(${PROJECT_NAME} PROPERTIES
- PREFIX ""
- LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
-)
-
-install(TARGETS ${PROJECT_NAME} DESTINATION ${PROJECT_DESTINATION})
-
-INSTALL(FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/config.json
- DESTINATION
- ${PROJECT_DESTINATION}
- )
-