summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorClément Bénier <clement.benier@iot.bzh>2018-05-28 14:32:22 +0200
committercle©mentbeénier <clement.benier@iot.bzh>2018-06-21 14:23:37 +0200
commit4bea2d73a5de0f8ec83c61edc37653718d34f31b (patch)
tree27bcf6901c168face30b593cb97c2460cb63a5b1 /CMakeLists.txt
parent42407a7e9f7e0bf29c7d8c679536eecb9c899e86 (diff)
initial commit: draft work in progress
Change-Id: I8c0c17c66a484df9bc152046466d80224cf65498 Signed-off-by: Clément Bénier <clement.benier@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..b485097
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)