summaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
authorClément Bénier <clement.benier@iot.bzh>2018-06-07 12:43:27 +0200
committercle©mentbeénier <clement.benier@iot.bzh>2018-06-21 14:23:37 +0200
commited02e81650ab383f11622c42bb1bfdd125e511f1 (patch)
treefe422bbf48c2af77efa68ca2969921018b6470a9 /binding/CMakeLists.txt
parent4bea2d73a5de0f8ec83c61edc37653718d34f31b (diff)
binding iiodevices: handles 3 iiodevices
handle accel, magn et anglvel iiodevices args key indicates the desired coordinates at subcription frequency can be also specified at subscription Example for subscription: - iiodevices subscribe { "event": "accel", "uid": "1", "args": "xyz", "frequency": "0.1" } - iiodevices subscribe { "event": "magn", "uid": "1", "args": "xz", "frequency": "0.1" } Change-Id: I7f300f56b5d69506434f31fbb6e552c7afdf7489 Signed-off-by: Clément Bénier <clement.benier@iot.bzh> Signed-off-by: clement benier <clement.benier@iot.bzh>
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
index 05992ff..4731dc5 100644
--- a/binding/CMakeLists.txt
+++ b/binding/CMakeLists.txt
@@ -18,13 +18,15 @@
###########################################################################
# Add target to project dependency list
-PROJECT_TARGET_ADD(accelero-binding)
+PROJECT_TARGET_ADD(iiodevices-binding)
# Define project Targets
- set(accelero_SOURCES
- accelero-binding.c)
+ set(iiodevices_SOURCES
+ iiodevices-binding.c
+ config_iiodevices.c
+ )
- add_library(${TARGET_NAME} MODULE ${accelero_SOURCES})
+ add_library(${TARGET_NAME} MODULE ${iiodevices_SOURCES})
# Binder exposes a unique public entry point
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
@@ -36,7 +38,3 @@ PROJECT_TARGET_ADD(accelero-binding)
# Library dependencies (include updates automatically)
TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})
-
- # installation directory
- INSTALL(TARGETS ${TARGET_NAME}
- LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})