summaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-12-05 11:06:07 +0100
committerScott Murray <scott.murray@konsulko.com>2017-12-20 19:24:21 -0500
commitd03590991d2c7104e7cd4b2a18e710008b2759ab (patch)
tree93f69d19982cc4ea4a3b6a317558e0b399492447 /binding/CMakeLists.txt
parentda737e24ee735b5dbcf773997ee1f42cd4cc9888 (diff)
Add conditional compilation option to enable using the 4A high-level API to request Multimedia role access. Change-Id: I85c19e33a355f9133bdda837e9374776fc92efe9 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh> Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
index 02f2aa9..2df218b 100644
--- a/binding/CMakeLists.txt
+++ b/binding/CMakeLists.txt
@@ -39,3 +39,6 @@ PROJECT_TARGET_ADD(afm-mediaplayer-binding)
INSTALL(TARGETS ${TARGET_NAME}
LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})
+ if(HAVE_4A_FRAMEWORK)
+ add_definitions(-DHAVE_4A_FRAMEWORK)
+ endif()