aboutsummaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-12-05 11:06:07 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-21 21:41:51 +0000
commite1d1561cd7061e5c2d72507e3ab367f94ed655d4 (patch)
tree043a3ea94f1ac12fb97f222f7403399c4c3defe0 /binding/CMakeLists.txt
parent381b4ed77c3b11efa5e7619253133146a44df911 (diff)
Add 4A support
Add conditional compilation option to enable using the 4A high-level API to request Multimedia role access. Change-Id: I85c19e33a355f9133bdda837e9374776fc92efe9 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh> Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit d03590991d2c7104e7cd4b2a18e710008b2759ab)
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
index 02f2aa9..2df218b 100644
--- a/binding/CMakeLists.txt
+++ b/binding/CMakeLists.txt
@@ -39,3 +39,6 @@ PROJECT_TARGET_ADD(afm-mediaplayer-binding)
INSTALL(TARGETS ${TARGET_NAME}
LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})
+ if(HAVE_4A_FRAMEWORK)
+ add_definitions(-DHAVE_4A_FRAMEWORK)
+ endif()