aboutsummaryrefslogtreecommitdiffstats
path: root/test/afb-test/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorEdi Feschiyan <edi.feschiyan@konsulko.com>2019-05-02 15:14:29 +0300
committerEdi Feschiyan <edi.feschiyan@konsulko.com>2019-06-18 00:22:35 +0300
commite457cf8cd7def62ac97e2b05b6d78726fc7ee96c (patch)
tree1b3d9129877a241ea0a6ebf6258abcca31fc29f1 /test/afb-test/tests/CMakeLists.txt
parent613dc2e97a53d3a6e4810303e4b2522bd985859d (diff)
Adding tests for agl-service-mediaplayer
Bug-AGL: SPEC-2525 Change-Id: Ib95aeaf94ead93a96c90041569db2714928e686d Signed-off-by: Edi Feschiyan <edi.feschiyan@konsulko.com>
Diffstat (limited to 'test/afb-test/tests/CMakeLists.txt')
-rw-r--r--test/afb-test/tests/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/test/afb-test/tests/CMakeLists.txt b/test/afb-test/tests/CMakeLists.txt
new file mode 100644
index 0000000..560a44c
--- /dev/null
+++ b/test/afb-test/tests/CMakeLists.txt
@@ -0,0 +1,31 @@
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# author:Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+##################################################
+# mediaplayer Lua Scripts
+##################################################
+PROJECT_TARGET_ADD(test-files)
+
+ file(GLOB LUA_FILES "*.lua" "*.sh")
+ add_input_files("${LUA_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "TEST-DATA"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+