summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-09-05 13:22:28 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2017-09-06 13:26:58 -0700
commitf2a2eefabf1252301070f249f2249758e648f5bf (patch)
tree95efc1c869a8190929b8745ec972298988770df1 /CMakeLists.txt
parent59a0665fe77d2b6ef155e84bce4333e555dce0dc (diff)
binding: media: add binding to its own repo
Initial commit for agl-service-media repo. This change enables cmake builds, and it being a standalone binding independent of the MediaPlayer application. Bug-AGL: SPEC-848 Change-Id: I1234c0d0dde4379b5697cc3fe3e16e27f8b73a7c Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..b485097
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)