summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStoyan Bogdanov <stoyan.bogdanov@konsulko.com>2019-06-12 16:12:39 +0300
committerStoyan Bogdanov <stoyan.bogdanov@konsulko.com>2019-06-18 11:41:45 +0300
commit089807fbbc4429ede68ef4fa846367345259de36 (patch)
treeada004340671ac5ee9b9b609ac646c637e8f3e98 /test/CMakeLists.txt
parent7eba64b591678e8e150ca5da0ea3537c3dd4db1f (diff)
tests: network: Add test bindings for agl-service-network
- Remove agl-service-network-ctl.c from tests folder. - Create the file and folders structure required. for building test bindings. Add all required Cmake files. - Create aft-agl-network.json configuration file for testing binding. - Create network.lua for testing bindings. Bug-AGL: SPEC-2515 Signed-off-by: Stoyan Bogdanov <stoyan.bogdanov@konsulko.com> Change-Id: I9df72a2d9d03189d3917c6e84f633af7603436b0
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt38
1 files changed, 25 insertions, 13 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 79065a4..2499cba 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,16 +1,28 @@
-###########################################
-# build and install afb-client-demo
-###########################################
-PKG_CHECK_MODULES(libsystemd libsystemd>=222)
-PKG_CHECK_MODULES(libafbwsc libafbwsc>=5.99)
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# Author: Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
-ADD_EXECUTABLE(agl-service-network-ctl agl-service-network-ctl.c)
-TARGET_LINK_LIBRARIES(agl-service-network-ctl
- ${link_libraries}
- ${libsystemd_LDFLAGS}
- ${libafbwsc_LDFLAGS}
-)
-INSTALL(TARGETS agl-service-network-ctl
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})
+
+ADD_TEST(NAME AGL_SERVICE_GPS_TESTS
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMAND afb-test.sh "${CMAKE_BINARY_DIR}/package" "${CMAKE_BINARY_DIR}/package-test" SERVICE
+ )