aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..79065a4
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,16 @@
+###########################################
+# build and install afb-client-demo
+###########################################
+PKG_CHECK_MODULES(libsystemd libsystemd>=222)
+PKG_CHECK_MODULES(libafbwsc libafbwsc>=5.99)
+
+ADD_EXECUTABLE(agl-service-network-ctl agl-service-network-ctl.c)
+
+TARGET_LINK_LIBRARIES(agl-service-network-ctl
+ ${link_libraries}
+ ${libsystemd_LDFLAGS}
+ ${libafbwsc_LDFLAGS}
+)
+INSTALL(TARGETS agl-service-network-ctl
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+