aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt38
1 files changed, 13 insertions, 25 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2499cba..79065a4 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,28 +1,16 @@
-###########################################################################
-# Copyright 2019 Konsulko Group
-#
-# Author: Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
+###########################################
+# build and install afb-client-demo
+###########################################
+PKG_CHECK_MODULES(libsystemd libsystemd>=222)
+PKG_CHECK_MODULES(libafbwsc libafbwsc>=5.99)
+ADD_EXECUTABLE(agl-service-network-ctl agl-service-network-ctl.c)
-# Include any directory not starting with _
-# -----------------------------------------------------
-PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})
-
-ADD_TEST(NAME AGL_SERVICE_GPS_TESTS
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND afb-test.sh "${CMAKE_BINARY_DIR}/package" "${CMAKE_BINARY_DIR}/package-test" SERVICE
- )
+TARGET_LINK_LIBRARIES(agl-service-network-ctl
+ ${link_libraries}
+ ${libsystemd_LDFLAGS}
+ ${libafbwsc_LDFLAGS}
+)
+INSTALL(TARGETS agl-service-network-ctl
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})