aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorFarshid Monhaseri <monhaseri.f@gmail.com>2020-11-10 13:05:37 +0330
committerFarshid Monhaseri <monhaseri.f@gmail.com>2020-11-10 09:55:46 +0000
commit172db50c33beeb53f8e75c115699179be880b960 (patch)
treeeb0b124e43cf409c4b12b72a4df1e12d3219936d /src/CMakeLists.txt
parente40da34d561aa802ea8f1d8f5bf7b5898f84b083 (diff)
Add device monitoring feature (hotplug device detection)
Changes: - Implement libudev 'monitor' interface to detect hotplug devices. - Forward udev rules as AFB 'subscribe' args to udev_monitoring objects. - Filter retrieved property fields through 'mask' argument from 'subscribe' args. - Generate detached threads (event loop) and data context for each client, so every user can subscribe for device events with their own udev rules and receive their desired device parameters. Bug-AGL: SPEC-3512 Signed-off-by: Farshid Monhaseri <monhaseri.f@gmail.com> Change-Id: I0fc007d9707deaf39d21147aa8240fde302f5f9e
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 45bc242..ae1da6a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -18,7 +18,10 @@
PROJECT_TARGET_ADD(platform-info)
# Define project Targets
- ADD_LIBRARY(${TARGET_NAME} MODULE platform-info-binding.c)
+ ADD_LIBRARY(${TARGET_NAME} MODULE
+ platform-info-binding.c
+ platform-info-devices.c
+ )
# Binder exposes a unique public entry point
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES