summaryrefslogtreecommitdiffstats
path: root/binding/src/CMakeLists.txt
diff options
context:
space:
mode:
authorShoichi Hiramatsu <hiramatsu_sh@micware.co.jp>2020-04-06 22:16:50 +0900
committerShoichi Hiramatsu <hiramatsu_sh@micware.co.jp>2020-04-09 14:09:32 +0900
commit0c6f41e5965d0013cd871659c52c9abb1057550c (patch)
tree6ac47c8435aa3ba5b3dce0e32a7d75d96a5e592f /binding/src/CMakeLists.txt
parent19a59202d0d3e2a2abdf64e6f8b74506443fd61b (diff)
Check in demonstration POI bindingjellyfish_9.99.1jellyfish/9.99.19.99.1
Bug-AGL: SPEC-3291 Signed-off-by: Shoichi Hiramatsu <hiramatsu_sh@micware.co.jp> Change-Id: Iac3488f240f7ae1c19fa6c650bcfcd240e88224a
Diffstat (limited to 'binding/src/CMakeLists.txt')
-rw-r--r--binding/src/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/binding/src/CMakeLists.txt b/binding/src/CMakeLists.txt
new file mode 100644
index 0000000..0ac597f
--- /dev/null
+++ b/binding/src/CMakeLists.txt
@@ -0,0 +1,36 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+# contrib: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(afm-poi-binding)
+
+ # Define project Targets
+ add_library(afm-poi-binding MODULE binding-api.h binding-api.c verbs.cpp)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "lib"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})
+