summaryrefslogtreecommitdiffstats
path: root/conf.d/project/data/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-04-23 14:22:26 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-07-05 15:43:07 +0200
commit4e68c9f6d3b303dd326a42e69556b22e0fe88438 (patch)
tree0661fe2e03568d19969127def348ecb2f6368303 /conf.d/project/data/CMakeLists.txt
parentfadb09c791fca941cadf39c467a54bf150417c54 (diff)
Make 2 set of configurations
1 for normal multi low level sources 1 for TXC-demo Future goal will be to merge them Also reorganize data resources files Bump app-template: Submodule conf.d/app-templates dd0cec7..30e78a5: > Adding cmake file at the root directory > Adds commit hash to the version. > Change default sample settings. Change-Id: I31838723da58fc33b25bc7cd5f42396a1805e34d Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'conf.d/project/data/CMakeLists.txt')
-rw-r--r--conf.d/project/data/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/conf.d/project/data/CMakeLists.txt b/conf.d/project/data/CMakeLists.txt
new file mode 100644
index 0000000..5c6a41b
--- /dev/null
+++ b/conf.d/project/data/CMakeLists.txt
@@ -0,0 +1,43 @@
+###########################################################################
+# Copyright 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+##################################################
+# Control Policy Config file
+##################################################
+PROJECT_TARGET_ADD(lua.d)
+
+ file(GLOB LUA_FILES "*.lua")
+
+ add_input_files("${LUA_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "DATA"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+PROJECT_TARGET_ADD(openxc-traces)
+
+ file(GLOB OPENXC_FILES "*.json")
+
+ add_input_files("${OPENXC_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "DATA"
+ OUTPUT_NAME ${TARGET_NAME}
+ )