summaryrefslogtreecommitdiffstats
path: root/controller/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-10-05 01:38:18 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-12-14 11:00:25 +0100
commit8df3e437f941912067231250ff5695b8a3a7fd92 (patch)
treec812fb252ad0f8a48041aff28b7fc60a75f245d1 /controller/CMakeLists.txt
parent8364673ab93eb484e25c7c4776e5d705b73330b4 (diff)
LUA lib and bin embedded in project
Change-Id: I1a61b49f55e4daa305800e754a14b6041aa81b34 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'controller/CMakeLists.txt')
-rw-r--r--controller/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/controller/CMakeLists.txt b/controller/CMakeLists.txt
index 6b4662e..5269bcc 100644
--- a/controller/CMakeLists.txt
+++ b/controller/CMakeLists.txt
@@ -15,6 +15,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
###########################################################################
+
# Include LUA only when requested
get_property(COMPDEF DIRECTORY PROPERTY COMPILE_DEFINITIONS)
if("CONTROL_SUPPORT_LUA=1" IN_LIST COMPDEF)
@@ -33,7 +34,7 @@ PROJECT_TARGET_ADD(afb-controller)
# Library dependencies (include updates automatically)
TARGET_LINK_LIBRARIES(${TARGET_NAME}
- afb-utilities
+ ${link_libraries}
)
# Define target includes for this target client