summaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2019-03-29 17:44:48 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2019-04-19 17:30:28 +0200
commitcbfe3d859515a593fbad5edd82f5a9162749476b (patch)
tree5deca53d5963be2e02dd7df0a1f94c5aa7203420 /plugins/CMakeLists.txt
parenta53418f75db2d4a9f0cb941de812b27024381b07 (diff)
Git submodule migration to separated librariesguppy_7.0.2guppy/7.0.27.0.2
Replace controller binder functions definition with the binder ones and remove the submodules in favor of the separated libraries. Bug-AGL: SPEC-2139 Change-Id: I06e5e7a03a918bf0ce139636104e1a73d2442a09 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'plugins/CMakeLists.txt')
-rw-r--r--plugins/CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
index c8ec93c..7fe36ff 100644
--- a/plugins/CMakeLists.txt
+++ b/plugins/CMakeLists.txt
@@ -29,13 +29,7 @@ PROJECT_TARGET_ADD(builtin)
OUTPUT_NAME ${TARGET_NAME}
)
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- ${link_libraries}
- )
-
target_include_directories(${TARGET_NAME}
- PRIVATE "../ctl-utilities/ctl-lib"
PRIVATE "../signal-composer-binding")
PROJECT_TARGET_ADD(low-can)
@@ -51,13 +45,7 @@ PROJECT_TARGET_ADD(low-can)
OUTPUT_NAME ${TARGET_NAME}
)
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- ${link_libraries}
- )
-
target_include_directories(${TARGET_NAME}
- PRIVATE "../ctl-utilities/ctl-lib"
PRIVATE "../signal-composer-binding")
PROJECT_TARGET_ADD(gps)
@@ -73,11 +61,5 @@ PROJECT_TARGET_ADD(gps)
OUTPUT_NAME ${TARGET_NAME}
)
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- ${link_libraries}
- )
-
target_include_directories(${TARGET_NAME}
- PRIVATE "../ctl-utilities/ctl-lib"
PRIVATE "../signal-composer-binding")