summaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-09-15 18:10:45 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-12-14 11:00:25 +0100
commit6e6aab21e97a22dfe459ab048531cf176ef79c98 (patch)
treec2c4d385e98dfd120bcd1a9b3d67d4d25f73ed6c /plugins/CMakeLists.txt
parent677cde6288a4574b8251a4a532b1d9e1594b09b2 (diff)
Adding GPS plugin to make the subscription
Change-Id: I838ec22ee246c7ad1b438a2777b1fd8af02433b7 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'plugins/CMakeLists.txt')
-rw-r--r--plugins/CMakeLists.txt21
1 files changed, 20 insertions, 1 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
index 106a237..2b21228 100644
--- a/plugins/CMakeLists.txt
+++ b/plugins/CMakeLists.txt
@@ -16,9 +16,28 @@
# limitations under the License.
###########################################################################
+PROJECT_TARGET_ADD(low-can)
+ # Define targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE ${TARGET_NAME}.c)
-PROJECT_TARGET_ADD(low-can)
+ # Alsa Plugin properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "PLUGIN"
+ PREFIX ""
+ SUFFIX ".ctlso"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ afb-utilities
+ ${link_libraries}
+ )
+
+ include_directories("../controller")
+
+PROJECT_TARGET_ADD(gps)
# Define targets
ADD_LIBRARY(${TARGET_NAME} MODULE ${TARGET_NAME}.c)