aboutsummaryrefslogtreecommitdiffstats
path: root/test/afb-test/etc/CMakeLists.txt
diff options
context:
space:
mode:
authorClément Malléjac <clementmallejac@gmail.com>2018-07-27 17:05:53 +0200
committerClément Malléjac <clementmallejac@gmail.com>2018-08-22 11:33:44 +0200
commit7697648397638b082ce3d3d824c8c128490fc7ce (patch)
tree9dd46cf134acabd57f90492b8d2f3be7bd7fe63c /test/afb-test/etc/CMakeLists.txt
parent92f0e16392712fb80954426722675292d551bf0c (diff)
Setup the project for afb-test framework
Wrote a couple of basic API tests Setup mock apis for the test binding Added script to launch tests on native Linux machines Change-Id: I606752e7b46cb2afdc10f3319a24ef15675faa3b Signed-off-by: Clément Malléjac <clementmallejac@gmail.com>
Diffstat (limited to 'test/afb-test/etc/CMakeLists.txt')
-rw-r--r--test/afb-test/etc/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/test/afb-test/etc/CMakeLists.txt b/test/afb-test/etc/CMakeLists.txt
new file mode 100644
index 0000000..567c186
--- /dev/null
+++ b/test/afb-test/etc/CMakeLists.txt
@@ -0,0 +1,31 @@
+###########################################################################
+# Copyright 2018 IoT.bzh
+#
+# author: Clément Malléjac <clementmallejac@gmail.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+##################################################
+# Signal-Composer test configuration files
+##################################################
+PROJECT_TARGET_ADD(afb-test-config)
+
+ file(GLOB CONF_FILES "*.json")
+
+ add_input_files("${CONF_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "TEST-CONFIG"
+ OUTPUT_NAME ${TARGET_NAME}
+ ) \ No newline at end of file