aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/CMakeLists.txt')
-rw-r--r--plugins/CMakeLists.txt27
1 files changed, 25 insertions, 2 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
index 9145b57..c0d7225 100644
--- a/plugins/CMakeLists.txt
+++ b/plugins/CMakeLists.txt
@@ -16,6 +16,29 @@
# limitations under the License.
###########################################################################
+PROJECT_TARGET_ADD(lua2c-interface)
+
+ # Define targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE ${TARGET_NAME}.c)
+
+ # Alsa Plugin properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "PLUGIN"
+ PREFIX ""
+ SUFFIX ".ctlso"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ afb-utilities
+ ${link_libraries}
+ )
+
+ target_include_directories(${TARGET_NAME}
+ PRIVATE "../controller"
+ PRIVATE "../signal-composer-binding")
+
PROJECT_TARGET_ADD(low-can)
# Define targets
@@ -59,5 +82,5 @@ PROJECT_TARGET_ADD(gps)
)
target_include_directories(${TARGET_NAME}
- PRIVATE "../controller"
- PRIVATE "../signal-composer-binding")
+ PRIVATE "../controller"
+ PRIVATE "../signal-composer-binding")