aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2018-06-06 10:59:44 +0900
committerKazumasa Mitsunari <knimitz@witz-inc.co.jp>2018-06-06 08:48:52 +0000
commita5da9bcbc5b3eb9a23cb97c8d3ef711c713e6c83 (patch)
tree215f7feb8accabb148a8a69e23397d5b3b0289ab /src/CMakeLists.txt
parent0c458cecd936c4263f46fe582afb91df7f5ed61c (diff)
* stream_close key : stream_id Calls disconnect function * set_stream_state key : stream_id key : mute value: 0 = unmute, 1 = mute Calls connect when mute is set to 0, then "stream_state_event" is published if success. This event is same as asyncSetSourceState like here. "event":"soundmanager\/stream_state_event", "data":{ "handle":value1, "sourceID":value2, "sourceState":"on|off|paused", "event_name":"ahl_stream_state_event", "stream_id":value1, "state_event":value } asyncSetSourceState is also published. And when mute is set to 1, then calls disconnect. "stream_id" is the returned value when application calls "stream_open". Change-Id: Ib8a032ed2c407605b6015441eccbb7660d9932d8 Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f157b7d..66e640f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -26,6 +26,7 @@ set(binding_sm_sources
soundmanager.c
sm-helper.c
sm-error.c
+ sm-pending.c
audiomanager_proxy.c
dbus/audio_manager_interface.c)