summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederic Marec <frederic.marec@iot.bzh>2020-02-18 16:30:04 +0100
committerFrederic Marec <frederic.marec@iot.bzh>2020-02-20 16:18:31 +0100
commit9b5a5abe9b65640691f4984052445839710e5819 (patch)
tree9d526dbcd6f34a6b52159da87819b541dc6b77ed /CMakeLists.txt
parent54d83caf8f92c6a68cf4e7fc067c31a5cc6880f1 (diff)
Update autobuild script to create multiple widget target debug, coverage and all Add config.cmake to match with cmake-app-module Adapt CMakeLists folowing those changes Bug-AGL: SPEC-2049 Signed-off-by: Frederic Marec <frederic.marec@iot.bzh> Change-Id: I17748ab91808c1e82cde0e354928bde63d89286b
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 2 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c343b3..3fe99ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,20 +14,6 @@
# limitations under the License.
#
-project(af-steering-wheel-binding C)
-
-cmake_minimum_required(VERSION 2.8)
-
-include(GNUInstallDirs)
-
-set(PROJECT_NAME "af-steering-wheel-binding")
-set(PROJECT_PRETTY_NAME "af binding for steering wheel")
-set(PROJECT_DESCRIPTION "Binding for handling Vehicle signalisation of steering wheel")
-set(PROJECT_VERSION "1.0")
-
-#set(CMAKE_BUILD_TYPE Debug)
-set(CMAKE_BUILD_TYPE Release)
-
-add_subdirectory(src)
-
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)