summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-07-31 17:30:17 +0900
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-08-10 10:19:16 +0900
commit183e61cb341a9bb394b1e933edb66284211ef7e6 (patch)
treeb2ebaab0cece1f5f57bceb82555986b7bf541595 /CMakeLists.txt
parentf9bdd961edde55b918129064578b0405d28281d0 (diff)
Add agl-service-steering-wheel
Add new binding service for steering wheel. Right now it's for logitech g29 and build on reneses m3ulcb. Had test on Daring Dab 3.99.2, 3.99.3, 4.0.0. After this commit, we want to add some code for dashboard to use this binding. [Modify 20170803] Deleted trailing whitespace in README.md Fixed typo enogh to enough Modfied .noconcurrency 0 to 1 for atomic Checked event valid by afb_event_is_valid Droped event when not enough memory by afb_event_drop [Modify 20170804] Modify json path into afb_daemon_rootdir_open_locale Delete error.h for same ERRMSG define in af-steering-wheel-binding.h Delete install code in recipes because aglwgt do autoinstall Add verbs information [Modify 20170808] Add target 'package' in CMakeLists.txt to make package [Modify 20170810] Add new folder named 'package' for jenkins job Change-Id: I975b1ce3afbeea0145ea723586b4b46288c987ab Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..4c343b3
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,33 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+project(af-steering-wheel-binding C)
+
+cmake_minimum_required(VERSION 2.8)
+
+include(GNUInstallDirs)
+
+set(PROJECT_NAME "af-steering-wheel-binding")
+set(PROJECT_PRETTY_NAME "af binding for steering wheel")
+set(PROJECT_DESCRIPTION "Binding for handling Vehicle signalisation of steering wheel")
+set(PROJECT_VERSION "1.0")
+
+#set(CMAKE_BUILD_TYPE Debug)
+set(CMAKE_BUILD_TYPE Release)
+
+add_subdirectory(src)
+
+