summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Jahnke <tobias.jahnke@microchip.com>2019-08-09 14:12:09 +0200
committerTobias Jahnke <tobias.jahnke@microchip.com>2019-08-12 08:52:11 +0200
commitfa46d3cd2c0166d064a720bd5e621b11751a9977 (patch)
tree17f954cd224f80557d615cb0db537c962e298c3c /CMakeLists.txt
parent114741ed6314cf042460804effdab399936585cc (diff)
unicens-controller: insert initial code of service
Bug-AGL: SPEC-2738 - adds service widget to control microphone mode, amplifier and slimamp master volume Signed-off-by: Tobias Jahnke <tobias.jahnke@microchip.com> Change-Id: I2463b0351c740c738e35185997d926a602bb2489 Signed-off-by: Tobias Jahnke <tobias.jahnke@microchip.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..92e59ce
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,19 @@
+################################################################################
+# Copyright 2019 Microchip Technology Inc. and its subsidiaries
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+################################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)