summaryrefslogtreecommitdiffstats
path: root/ucs2-vol/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Jahnke <tjahnk@users.noreply.github.com>2017-08-18 13:46:58 +0200
committerTobias Jahnke <tjahnk@users.noreply.github.com>2017-08-18 13:46:58 +0200
commit1b245760ed8a3476a9288e39965a23e1d50b085a (patch)
tree446055f48fe614d3b5bc7f247e5586d84b9b67a0 /ucs2-vol/src/CMakeLists.txt
parent29a81bf7ace46f80e12470e984c54d9884e47a57 (diff)
removed volume API
Diffstat (limited to 'ucs2-vol/src/CMakeLists.txt')
-rw-r--r--ucs2-vol/src/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/ucs2-vol/src/CMakeLists.txt b/ucs2-vol/src/CMakeLists.txt
deleted file mode 100644
index 64ef536..0000000
--- a/ucs2-vol/src/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(ucs2-vol)
-
-# Define targets source files
-ADD_LIBRARY(ucs2-vol STATIC callbacks.cpp device_container.cpp device_value.cpp libmostvolume.cpp setup.cpp)
-
- # Expose Library Properties
- SET_TARGET_PROPERTIES(ucs2-vol PROPERTIES OUTPUT_NAME ucs2vol)
-
- # Library dependencies from PKG_REQUIRED_LIST
- TARGET_LINK_LIBRARIES(ucs2-vol # Library dependencies (include updates automatically)
- ucs2-lib
- ${link_libraries}
- )
-
- # Define properties to expose when others use this target
- TARGET_INCLUDE_DIRECTORIES(ucs2-vol
- PUBLIC
- ${CMAKE_CURRENT_SOURCE_DIR}/../inc
- ${CMAKE_CURRENT_SOURCE_DIR}/../cfg
- ${CMAKE_CURRENT_SOURCE_DIR}/ucs-xml
- )
-