aboutsummaryrefslogtreecommitdiffstats
path: root/ucs2-interface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ucs2-interface/CMakeLists.txt')
-rw-r--r--ucs2-interface/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/ucs2-interface/CMakeLists.txt b/ucs2-interface/CMakeLists.txt
index 8cd797c..f96d491 100644
--- a/ucs2-interface/CMakeLists.txt
+++ b/ucs2-interface/CMakeLists.txt
@@ -20,17 +20,18 @@
PROJECT_TARGET_ADD(ucs2-inter)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNDEBUG")
+ # Search for libs
+ find_package (LibXml2 REQUIRED)
+
# Define targets
ADD_LIBRARY(ucs2-inter STATIC ucs_lib_interf.c ucs-xml/UcsXml.c ucs-xml/UcsXml_Private.c)
-
# Library properties
SET_TARGET_PROPERTIES(ucs2-inter PROPERTIES OUTPUT_NAME ucs2interface)
# Depends on Unicens2 lib
- TARGET_LINK_LIBRARIES(ucs2-inter ucs2-lib mxml)
+ TARGET_LINK_LIBRARIES(ucs2-inter ucs2-lib ${LIBXML2_LIBRARIES})
# Define includes
TARGET_INCLUDE_DIRECTORIES(ucs2-inter
- PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}
- INTERFACE mxml
+ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} ${LIBXML2_INCLUDE_DIR}
)