aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-06-16 18:49:45 +0530
committerAnuj Solanki <anuj603362@gmail.com>2024-09-07 20:16:14 +0530
commit1144fcd343bc56f8c27ff73d3e76904010dbb832 (patch)
tree490915cd969f19b4eb3b3dd480554b27c1058243 /setup.py
parentf2b62ba4da5a178221c3210c2d468cd684e626cc (diff)
Integrate Whisper AI into agl-service-voiceagent
V1: - Integrated Whisper AI for speech-to-text functionality into agl-service-voiceagent. - Add support for both online and offline mode. - Implemented a gRPC-based connection for online mode between Whisper ASR service and voice-agent service. V2: - Update kuksa-interface - Add whisper-cpp for speech-to-text functionality - Add support to control media using mpd - Fix audio recorder Bug-AGL: SPEC-5200 Change-Id: I2661ae61ba2c3283bcfde26d6e4f498270240b19 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 99f6ace..f8bdcb4 100644
--- a/setup.py
+++ b/setup.py
@@ -16,11 +16,12 @@ setup(
"grpcio-tools>=1.45.0",
"vosk==0.3.42",
"PyGObject==3.42.0",
- "rasa==3.6.4",
- "numpy==1.22.3",
- "tensorflow==2.12.0",
- "tensorboard==2.12.0",
- "keras==2.12.0",
+ "rasa==3.7.0b2",
+ "numpy==1.26.4",
+ "tensorflow",
+ "tensorboard",
+ "keras==3.4.0",
+ "openai-whisper"
],
license="Apache-2.0",
python_requires=">=3.9",