aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 9c608e7..2c8bf18 100644
--- a/setup.py
+++ b/setup.py
@@ -5,15 +5,15 @@ packages = [p for p in find_packages()
setup(
name="agl_service_voiceagent",
- version="0.2.0",
+ version="0.3.0",
description="A gRPC-based voice agent service designed for Automotive Grade Linux (AGL). This service leverages GStreamer, Vosk, Snips, and RASA to seamlessly process user voice commands. It converts spoken words into text, extracts intents from these commands, and performs actions through the Kuksa interface.",
url="https://github.com/malik727/agl-service-voiceagent",
author="Malik Talha",
author_email="talhamalik727x@gmail.com",
install_requires=[
"kuksa-client==0.4.0",
- "grpcio==1.45.0",
- "grpcio-tools==1.45.0",
+ "grpcio>=1.45.0",
+ "grpcio-tools>=1.45.0",
"vosk==0.3.42",
"PyGObject==3.42.0",
"rasa==3.6.4",
@@ -31,5 +31,5 @@ setup(
"console_scripts": [
"voiceagent-service=agl_service_voiceagent.service:main"
],
- },
+ }
) \ No newline at end of file