summaryrefslogtreecommitdiffstats
path: root/binding-wifi/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-08-11 12:31:35 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2017-08-11 18:48:55 -0700
commitaf8fd545eee24fb2d6a8d472912f9c606b044278 (patch)
tree4e136a2b7a9524a53af669d76883f9a03b83c9e7 /binding-wifi/CMakeLists.txt
parent90891cc99c6be8002302e5b68e205cb43df91636 (diff)
Switch from legacy qmake to cmake to build binding Bug-AGL: SPEC-823 Change-Id: I55532be199415a4d4adb441446c1143da9ef8edf Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'binding-wifi/CMakeLists.txt')
-rw-r--r--binding-wifi/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/binding-wifi/CMakeLists.txt b/binding-wifi/CMakeLists.txt
new file mode 100644
index 0000000..54fef96
--- /dev/null
+++ b/binding-wifi/CMakeLists.txt
@@ -0,0 +1,43 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+# contrib: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(wifi-binding)
+
+ # Define project Targets
+ add_library(${TARGET_NAME} MODULE
+ agent.c
+ wifi-api.c
+ wifi-connman.c)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "libafm-"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})
+
+ # installation directory
+ INSTALL(TARGETS ${TARGET_NAME}
+ LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})
+