aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2018-06-23 08:42:45 +0900
committerKazumasa Mitsunari <knimitz@witz-inc.co.jp>2018-06-25 01:33:18 +0000
commitbe9cbe2c4d0bc0f65cbe08de2bad3eb6e7f248c0 (patch)
treeb7d22d2b23749993b6448ed77c65752335a219b9 /src/CMakeLists.txt
parent43ff4c2624e34b9cfbc3f13036fa449b5f46e9b0 (diff)
Clean: remove useless headers
* Shorten build time * Remove unnecessary dependencies Change-Id: I960b2a21124cabc62ef73436fb5a7ab5191c4e0d Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cc3efc3..47d4bf8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -28,22 +28,13 @@ set(TARGETS_WM windowmanager-service)
add_library(${TARGETS_WM} MODULE
main.cpp
wayland_ivi_wm.cpp
- wayland_ivi_wm.hpp
util.cpp
- util.hpp
layout.cpp
- layout.hpp
${IVI_CON_PROTO}
json_helper.cpp
- json_helper.hpp
- app.hpp app.cpp
- result.hpp
+ app.cpp
layers.cpp
- layers.hpp
- controller_hooks.hpp
- config.cpp
- config.hpp
- policy.hpp)
+ config.cpp)
target_include_directories(${TARGETS_WM}
PRIVATE