aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2018-08-22 19:57:51 +0900
committerKazumasa Mitsunari <knimitz@witz-inc.co.jp>2018-08-22 19:57:51 +0900
commit5d36c79042c3f513392cb765940252acb860b7a9 (patch)
tree0123da60ebb51941c51231e693d9cfd0692065b5 /src/CMakeLists.txt
parent4ba2fdbfb065c971f4a0b9b1dbab8957e7fba38d (diff)
Start to rework using ilmControl
Change-Id: Icfffea4c0587828f4dd863e9000e8aadb135c048 Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 6 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 192e2b2..6ac3022 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,10 +14,9 @@
# limitations under the License.
#
-wlproto(IVI_CON ivi-wm)
-
include(FindPkgConfig)
pkg_check_modules(AFB REQUIRED afb-daemon)
+pkg_check_modules(ILM REQUIRED ilmControl ilmCommon)
pkg_check_modules(SD REQUIRED libsystemd>=222)
# We do not want a prefix for our module
@@ -27,18 +26,14 @@ set(TARGETS_WM windowmanager-service)
add_library(${TARGETS_WM} MODULE
main.cpp
- wayland_ivi_wm.cpp
util.cpp
- layout.cpp
- ${IVI_CON_PROTO}
json_helper.cpp
- window_manager.cpp
- layers.cpp
- wm_client.cpp
- wm_error.cpp
applist.cpp
request.cpp
pm_wrapper.cpp
+ window_manager.cpp
+ wm_client.cpp
+ wm_error.cpp
wm_layer.cpp
wm_layer_control.cpp)
@@ -46,6 +41,7 @@ target_include_directories(${TARGETS_WM}
PRIVATE
${AFB_INCLUDE_DIRS}
${SD_INCLUDE_DIRS}
+ ${ILM_INCLUDE_DIRS}
../include
../src
../${PLUGIN_PM})
@@ -54,6 +50,7 @@ target_link_libraries(${TARGETS_WM}
PRIVATE
${AFB_LIBRARIES}
${WLC_LIBRARIES}
+ ${ILM_LIBRARIES}
${SD_LIBRARIES}
${PLUGIN_PM})