aboutsummaryrefslogtreecommitdiffstats
path: root/src/policy_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-19 13:08:17 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-19 15:22:29 +0000
commitc6f9a9b8468b3746a3dec7ee2a0b7d84ec9fb44a (patch)
treee766e0b4b1bb894c5511ed6d1e71a4ac389415d6 /src/policy_manager/CMakeLists.txt
parente4222ca8da3b02afca5625fa2cef6832aa8ce90e (diff)
Revert "Add PolicyManager as plugin"
This reverts commit 99b6f4d2fcd421d3a760a88a67e511fb6fc98068. Change-Id: I8725ca05a3e3fa0ea9e1db935e9e7d5b85a9affd
Diffstat (limited to 'src/policy_manager/CMakeLists.txt')
-rw-r--r--src/policy_manager/CMakeLists.txt65
1 files changed, 0 insertions, 65 deletions
diff --git a/src/policy_manager/CMakeLists.txt b/src/policy_manager/CMakeLists.txt
deleted file mode 100644
index 62e5ee9..0000000
--- a/src/policy_manager/CMakeLists.txt
+++ /dev/null
@@ -1,65 +0,0 @@
-#
-# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-include(FindPkgConfig)
-
-# We do not want a prefix for our module
-set(CMAKE_SHARED_MODULE_PREFIX "")
-
-set(TARGETS_PM lib${PLUGIN_PM})
-
-add_library(${TARGETS_PM} MODULE
- policy_manager.cpp
-)
-
-target_include_directories(${TARGETS_PM}
- PRIVATE
- ../../include
- ../
- ./
- ./stm/${USE_STM_NAME}/src/include
-)
-
-target_link_libraries(${TARGETS_PM}
- PRIVATE
- ${CMAKE_BINARY_DIR}/src/${PLUGIN_PM}/stm/${USE_STM_NAME}/src/libstm.so
-)
-
-target_compile_definitions(${TARGETS_PM}
- PRIVATE
- _GNU_SOURCE
-)
-
-target_compile_options(${TARGETS_PM}
- PRIVATE
- -Wall -Wextra -Wno-unused-parameter -Wno-comment)
-
-set_target_properties(${TARGETS_PM}
- PROPERTIES
- CXX_EXTENSIONS OFF
- CXX_STANDARD 14
- CXX_STANDARD_REQUIRED ON
-
- C_EXTENSIONS OFF
- C_STANDARD 99
- C_STANDARD_REQUIRED ON
-)
-
-install(
- TARGETS ${TARGET_PM}
- DESTINATION ${CMAKE_INSTALL_LIBDIR}
- COMPONENT "runtime"
-)