aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2018-05-25 11:20:12 +0900
committerKazumasa Mitsunari <knimitz@witz-inc.co.jp>2018-05-25 11:30:06 +0900
commitb04339fc03543cbd34b6e9db7adc9eb35caed5c0 (patch)
treebf4240590cc42313ed970451b602c3affb3b793c /test/CMakeLists.txt
parent5ac52dc6412f8311b6cfbd0e99652c914d5c6168 (diff)
Add unit test
Change-Id: Idb7c75c3c9d9b575cee75dc487fe6a7c0548b6ec Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt66
1 files changed, 66 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..8c693ce
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,66 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+cmake_minimum_required(VERSION 2.8)
+
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(AFB QUIET afb-daemon)
+pkg_check_modules(GT REQUIRED gtest)
+
+INCLUDE(FindThreads)
+FIND_PACKAGE(Threads)
+
+add_definitions(-DGTEST_ENABLED)
+
+set(TARGET_TEST wmtest)
+set(GTEST_ROOT /home/mitsunari/test/googletest/googletest)
+
+include_directories(${GTEST_ROOT}/include/)
+
+link_directories(${GTEST_ROOT}/build/)
+add_executable(${TARGET_TEST}
+ test.cpp
+ windowmanager-client.cpp
+ applist.cpp
+ request.cpp
+)
+
+target_include_directories(${TARGET_TEST}
+ PRIVATE
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${AFB_INCLUDE_DIRS}
+ ${GT_INCLUDE_DIRS}
+ ../include
+ ../src)
+
+target_link_libraries(${TARGET_TEST}
+ PRIVATE
+ ${AFB_LIBRARIES}
+ ${GT_LIBRARIES}
+ pthread
+)
+
+set_target_properties(${TARGET_TEST}
+ PROPERTIES
+ # INTERPROCEDURAL_OPTIMIZATION ON
+
+ CXX_EXTENSIONS OFF
+ CXX_STANDARD 14
+ CXX_STANDARD_REQUIRED ON
+
+ C_EXTENSIONS OFF
+ C_STANDARD 99
+ C_STANDARD_REQUIRED ON
+)