aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1cb0db..7e1cee1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,22 +59,6 @@ macro(wlproto var_basename proto_xml_basename)
include_directories(${CMAKE_CURRENT_BINARY_DIR})
endmacro()
-# Should modernize the following somehow...
-set(ENABLE_DEBUG_OUTPUT OFF CACHE BOOL "Enable debug logging")
-if(ENABLE_DEBUG_OUTPUT)
- add_definitions(-DDEBUG_OUTPUT)
-else()
- remove_definitions(-DDEBUG_OUTPUT)
-endif()
-
-# Should modernize the following somehow...
-set(ENABLE_SCOPE_TRACING OFF CACHE BOOL "Enable scope enter/leave messages for certain parts of the code.")
-if(ENABLE_SCOPE_TRACING)
- add_definitions(-DSCOPE_TRACING)
-else()
- remove_definitions(-DSCOPE_TRACING)
-endif()
-
set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. 'address', 'thread', 'leak', 'undefined'), depends on compiler; default none")
set(LINK_LIBCXX OFF CACHE BOOL "Link against LLVMs libc++")