aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2019-01-29 13:18:17 +0900
committerKazumasa Mitsunari <knimitz@witz-inc.co.jp>2019-02-04 19:54:01 +0900
commita0fa6394c0d8b7997343d6f2a44d9c2868f4be5f (patch)
tree33dee52eb43bfbf77fafbcecbe5e96a062179853 /CMakeLists.txt
parentb72e372690e677c38fa9b5ae90fb7fbe5a575c76 (diff)
Fix top surface becomes invisible when background surface is crashed.
Fix top surface becomes invisible when surface on same layer, such like application layer, is crashed. To fix this issue, I refactored attaching app to layer. Originally, window manager attached app to surface. This patch is the backport of master branch. Bug-AGL : SPEC-1635 Change-Id: Ie6713e669a25662e8547aa7782551ddae60c7e01 Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt49
1 files changed, 0 insertions, 49 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1cb0db..8a69a43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,55 +26,6 @@ set(PACKAGE_VERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}.${PACKAGE
find_package(PkgConfig REQUIRED)
include(GNUInstallDirs)
-pkg_check_modules(WLC wayland-client>=1.11.0 REQUIRED)
-
-macro(wlproto var_basename proto_xml_basename)
- if("${WLSCAN}" STREQUAL "")
- find_program(WLSCAN NAMES wayland-scanner)
- endif()
-
- if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/protocol)
- set(proto_dir "${CMAKE_CURRENT_SOURCE_DIR}/protocol")
- elseif(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/../protocol)
- set(proto_dir "${CMAKE_CURRENT_SOURCE_DIR}/../protocol")
- else()
- message(FATAL_ERROR "Could not find ${CMAKE_CURRENT_SOURCE_DIR}/protocol or ${CMAKE_CURRENT_SOURCE_DIR}/../protocol")
- endif()
-
- add_custom_command(
- OUTPUT
- ${proto_xml_basename}-protocol.c
- #${proto_xml_basename}-server-protocol.h
- ${proto_xml_basename}-client-protocol.h
- MAIN_DEPENDENCY ${proto_dir}/${proto_xml_basename}.xml
- COMMAND ${WLSCAN} code < ${proto_dir}/${proto_xml_basename}.xml > ${proto_xml_basename}-protocol.c
- #COMMAND ${WLSCAN} server-header < ${proto_dir}/${proto_xml_basename}.xml > ${proto_xml_basename}-server-protocol.h
- COMMAND ${WLSCAN} client-header < ${proto_dir}/${proto_xml_basename}.xml > ${proto_xml_basename}-client-protocol.h
- )
-
- set(${var_basename}_PROTO ${CMAKE_CURRENT_BINARY_DIR}/${proto_xml_basename}-protocol.c)
- set(${var_basename}_CLIENT ${CMAKE_CURRENT_BINARY_DIR}/${proto_xml_basename}-client-protocol.h)
- #set(${var_basename}_SERVER ${CMAKE_CURRENT_BINARY_DIR}/${proto_xml_basename}-server-protocol.h)
-
- include_directories(${CMAKE_CURRENT_BINARY_DIR})
-endmacro()
-
-# Should modernize the following somehow...
-set(ENABLE_DEBUG_OUTPUT OFF CACHE BOOL "Enable debug logging")
-if(ENABLE_DEBUG_OUTPUT)
- add_definitions(-DDEBUG_OUTPUT)
-else()
- remove_definitions(-DDEBUG_OUTPUT)
-endif()
-
-# Should modernize the following somehow...
-set(ENABLE_SCOPE_TRACING OFF CACHE BOOL "Enable scope enter/leave messages for certain parts of the code.")
-if(ENABLE_SCOPE_TRACING)
- add_definitions(-DSCOPE_TRACING)
-else()
- remove_definitions(-DSCOPE_TRACING)
-endif()
-
set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. 'address', 'thread', 'leak', 'undefined'), depends on compiler; default none")
set(LINK_LIBCXX OFF CACHE BOOL "Link against LLVMs libc++")