summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-05-27 14:24:22 -0400
committerScott Murray <scott.murray@konsulko.com>2020-05-27 14:27:56 -0400
commitc0208be2fdd6d30d59b534b848c1f4ce39a764d5 (patch)
treee98eaded50026086d934b27ad6363db15151de33 /CMakeLists.txt
parente81c43b394aba2766cea5ce7f410d56f70e7464a (diff)
Update to use CMake app template
Rework CMake files to actually use the CMake app template macros, with an update of the autobuild script to fix test widget building to match the state of the other bindings. Bug-AGL: SPEC-2049 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I88c438ed4dafd631646769d7b6dc3debd1ccd6de
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 5 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a69a43..98f77f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,6 @@
#
# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+# Copyright (C) 2020 Konsulko Group
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -14,24 +15,13 @@
# limitations under the License.
#
-cmake_minimum_required(VERSION 2.8)
-
project(WindowManagerTMC)
-set(PACKAGE_VERSION_MAJOR 0)
-set(PACKAGE_VERSION_MINOR 0)
-set(PACKAGE_VERSION_REVISION 1)
-set(PACKAGE_VERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}.${PACKAGE_VERSION_REVISION}")
-
-find_package(PkgConfig REQUIRED)
-include(GNUInstallDirs)
-
-set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. 'address', 'thread', 'leak', 'undefined'), depends on compiler; default none")
-
-set(LINK_LIBCXX OFF CACHE BOOL "Link against LLVMs libc++")
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
# Add PolicyManager as plugin
set(PLUGIN_PM policy_manager)
-add_subdirectory(${PLUGIN_PM})
-add_subdirectory(src)
+set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. 'address', 'thread', 'leak', 'undefined'), depends on compiler; default none")
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)