summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederic Marec <frederic.marec@iot.bzh>2020-02-18 16:22:55 +0100
committerFrederic Marec <frederic.marec@iot.bzh>2020-02-20 17:21:43 +0100
commitde70b5f128a2b993e88020ff717e763a53e385f7 (patch)
tree561fc2bff8227978849239c6dd294578f2444ad6 /CMakeLists.txt
parentc0adba3e6e8527c67d4d7699c9a8d8248f07b843 (diff)
Update autobuild script to create new targets
Update autobuild script to create multiple widget target debug, coverage and all Add config.cmake to match with cmake-app-module Adapt CMakeLists folowing those changes Bug-AGL: SPEC-2049 Signed-off-by: Frederic Marec <frederic.marec@iot.bzh> Change-Id: I1e96c97df7a501a5d69f51c23b325be91af2b60d
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 2 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a69a43..feaa536 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,24 +14,7 @@
# limitations under the License.
#
-cmake_minimum_required(VERSION 2.8)
-project(WindowManagerTMC)
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
-set(PACKAGE_VERSION_MAJOR 0)
-set(PACKAGE_VERSION_MINOR 0)
-set(PACKAGE_VERSION_REVISION 1)
-set(PACKAGE_VERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}.${PACKAGE_VERSION_REVISION}")
-
-find_package(PkgConfig REQUIRED)
-include(GNUInstallDirs)
-
-set(SANITIZER_MODE "none" CACHE STRING "Build using a specific sanitizer (e.g. 'address', 'thread', 'leak', 'undefined'), depends on compiler; default none")
-
-set(LINK_LIBCXX OFF CACHE BOOL "Link against LLVMs libc++")
-
-# Add PolicyManager as plugin
-set(PLUGIN_PM policy_manager)
-add_subdirectory(${PLUGIN_PM})
-
-add_subdirectory(src)
+include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)