summaryrefslogtreecommitdiffstats
path: root/policy_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-06 10:05:47 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-07 09:15:24 -0500
commit24794d197e6d27fbfba9790be1da190fe573a058 (patch)
tree7d506a9a319fdf3823fab40c5e37825c60e69430 /policy_manager/CMakeLists.txt
parent6a20800629fca350b00ce71a09ba4d71e2f2ee1d (diff)
Add configuration file over-ride mechanism
Reusing the windowmanager on the cluster demo platform requires modifications to the layers.json, areas.db, etc. configuration files. To allow this without breaking potential shared package feeds by building two versions, add a mechanism to allow over-riding the configuration files present in the widget with files in the directory /etc/xdg/windowmanager. Affected code has been refactored to use a new common configuration file path determination helper function to reduce duplication. Bug-AGL: SPEC-1805 Change-Id: Ia3e1af0703794079f9537b934b124788129c045c Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'policy_manager/CMakeLists.txt')
-rw-r--r--policy_manager/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/policy_manager/CMakeLists.txt b/policy_manager/CMakeLists.txt
index 584d311..3ec4c39 100644
--- a/policy_manager/CMakeLists.txt
+++ b/policy_manager/CMakeLists.txt
@@ -45,6 +45,7 @@ add_library(${TARGETS_PM}
SHARED
policy_manager.cpp
stm/stm.c
+ ../src/util.cpp
)
target_include_directories(${TARGETS_PM}