summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2017-12-19 13:35:55 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-19 09:36:53 +0000
commit3f23c8903f4f67bce8d4c4c8d5b9762f06daefc7 (patch)
tree65aea0889bc4c21a47a91dcb3b266a6bea1b8689 /src/CMakeLists.txt
parentb3f280dd0264f05626d5bc7d896f4b33c9f01e3d (diff)
Remove automatic code generation
To handle the request from binder(applications) more flexibly, we have to remove automatic code generation. Change-Id: Id14ab749cca68b5aa30376ba3ac543372df87233 Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 25849de..e508287 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -23,11 +23,6 @@ pkg_check_modules(SD REQUIRED libsystemd>=222)
# We do not want a prefix for our module
set(CMAKE_SHARED_MODULE_PREFIX "")
-add_custom_command(
- OUTPUT afb_binding_api.hpp afb_binding_glue.inl
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../generate-binding-glue.py
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/../generate-binding-glue.py)
-
set(TARGETS_WM windowmanager-service)
add_library(${TARGETS_WM} MODULE
@@ -45,7 +40,6 @@ add_library(${TARGETS_WM} MODULE
afb_binding_api.cpp
result.hpp
afb_binding_api.hpp
- afb_binding_glue.inl
layers.cpp
layers.hpp
controller_hooks.hpp