summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-11-30 21:07:10 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-11-30 21:07:10 +0000
commit2b1bf85afe0a8b24f75386f7c24df85f9b785bd3 (patch)
tree8b727b720dd475deb8fbd52ec0cae83613b156ec /src/CMakeLists.txt
parentd1188744973931f66a83968310175369cd85c231 (diff)
parentd9dc8ef258ed2ddeeca83775eee945dbfdae59c5 (diff)
Merge "Migrates bindings v3"guppy_6.99.2guppy/6.99.26.99.2
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d2b16ae..fc19a18 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -56,7 +56,7 @@ target_link_libraries(${TARGETS_WM}
target_compile_definitions(${TARGETS_WM}
PRIVATE
- AFB_BINDING_VERSION=2
+ AFB_BINDING_VERSION=3
# We do not want source location of messages
AFB_BINDING_PRAGMA_NO_VERBOSE_DETAILS
WINMAN_VERSION_STRING="${PACKAGE_VERSION}"
@@ -70,7 +70,7 @@ endif()
target_compile_options(${TARGETS_WM}
PRIVATE
- -Wall -Wextra -Wno-unused-parameter -Wno-comment)
+ -Wall -Wextra -Wno-unused-parameter -Wno-comment -Wno-missing-field-initializers)
set_target_properties(${TARGETS_WM}
PROPERTIES