aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorYuta Doi <yuta-d@witz-inc.co.jp>2018-04-27 19:01:36 +0900
committerYuta Doi <yuta-d@witz-inc.co.jp>2018-04-27 19:01:36 +0900
commit55be85ed4bdfea6fc037d781b8cd8f58487718d1 (patch)
tree279a88e26c74aee58f11e2a5d20348569ce34667 /src/CMakeLists.txt
parentd50188f726b15a0ae2777bf2d91ee88836feeac5 (diff)
Add PolicyManager, related classes and some config files
- PolicyManager Decide next layout by using occured event and current state based on policy table. This PolicyManger is reference and the OEMs can replace it. - LayoutManager Change the current layout to the layout which decided by PolicyManager. NOTE: The functions of this class had been included in App class. The part of function of this class remain there yet. - LowCanClient Receive the CAN signal from low level CAN service. - app.db Define the applications name and its role. This file will be deleted when the names and roles can be given by other module. - layout.cb Define the layouts and areas which are included by the layout. - role.db Define the roles of the applications. Change-Id: I2f84bdf5e68355e022f516cee9a1db88efe58825 Signed-off-by: Yuta Doi <yuta-d@witz-inc.co.jp>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt24
1 files changed, 19 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cc3efc3..a632b9c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -25,14 +25,17 @@ set(CMAKE_SHARED_MODULE_PREFIX "")
set(TARGETS_WM windowmanager-service)
+# Set use STM name
+set(USE_STM_NAME zipc)
+
add_library(${TARGETS_WM} MODULE
main.cpp
wayland_ivi_wm.cpp
wayland_ivi_wm.hpp
util.cpp
util.hpp
- layout.cpp
- layout.hpp
+ layout_manager/layout.cpp
+ layout_manager/layout.hpp
${IVI_CON_PROTO}
json_helper.cpp
json_helper.hpp
@@ -43,20 +46,28 @@ add_library(${TARGETS_WM} MODULE
controller_hooks.hpp
config.cpp
config.hpp
- policy.hpp)
+ low_can_client.cpp
+ low_can_client.hpp
+)
target_include_directories(${TARGETS_WM}
PRIVATE
${AFB_INCLUDE_DIRS}
${SD_INCLUDE_DIRS}
../include
- ../src)
+ ../src
+ ../src/layout_manager
+ ../src/${PLUGIN_PM}
+ ../src/${PLUGIN_PM}/${USE_STM_NAME}
+)
target_link_libraries(${TARGETS_WM}
PRIVATE
${AFB_LIBRARIES}
${WLC_LIBRARIES}
- ${SD_LIBRARIES})
+ ${SD_LIBRARIES}
+ ${PLUGIN_PM}
+)
target_compile_definitions(${TARGETS_WM}
PRIVATE
@@ -116,6 +127,9 @@ add_custom_command(TARGET ${TARGETS_WM} POST_BUILD
COMMAND cp -rf ${PROJECT_BINARY_DIR}/src/${TARGETS_WM}.so ${PROJECT_BINARY_DIR}/package/root/lib
COMMAND mkdir -p ${PROJECT_BINARY_DIR}/package/root/etc
COMMAND cp -f ${PROJECT_SOURCE_DIR}/layers.json ${PROJECT_BINARY_DIR}/package/root/etc
+ COMMAND cp -f ${PROJECT_SOURCE_DIR}/src/layout_manager/db/layout.db ${PROJECT_BINARY_DIR}/package/root/etc
+ COMMAND cp -f ${PROJECT_SOURCE_DIR}/src/${PLUGIN_PM}/db/role.db ${PROJECT_BINARY_DIR}/package/root/etc
+ COMMAND cp -f ${PROJECT_SOURCE_DIR}/src/db/app.db ${PROJECT_BINARY_DIR}/package/root/etc
)
add_custom_target(package DEPENDS ${PROJECT_BINARY_DIR}/package/root